How To Remove Branding From a Dell OEM Server

NOTE: This is for Dell OEM systems only, run at your own risk.

Recently I have RMAed motherboards for non-branded Dell servers. The problem I ran into is I was getting branded system boards back when I had originally had non-branded. The non-branded BIOSes would just be blank with a progress bar instead of having the Dell logo. I ended up spending more time and energy talking to Dell again trying to get boards to my specifications. I was told by several Dell engineers that unfortunately there was no way to fix this other than the factory setting the board up.

Well they were wrong, and because I didn’t find this anywhere online I am going to detail the instructions. Note: this is ONLY for people who need to un-brand systems from Dell, I have done this with 12th Generation servers and nothing else.

  1. Remove the old motherboard, and install the new motherboard into the chassis
  2. Now the first thing Dell training says is to set the service tag on the system now, DO NOT DO THIS YET
    • If you set the service tag, the unbranding tool will not work. If you have already set the service tag, more than likely by booting to DOS and using ftp://ftp.dell.com/utility/asset_a209.com, then you can still fix this. Boot back to DOS and use the tool again, except with “asset_~1 /s /d”. This is an undocumented feature that will remove the service tag of the box.
  3. Start up any version of Windows that is at least Windows Vista loaded. I used Windows 8 because you can get a 90 day evaluation for free. And that is enough for me to do what work I need done on the box before handing it over.
  4. Go to Support.Dell.com, and look up the box by the service tag to get to the OEM support site. If you don’t have the service tag, look up the generic version and get the url, currently for a R720 it looks like this http://www.dell.com/support/troubleshooting/us/en/04/Product/poweredge-r620. Now if you replace “poweredge” with “oth” you get the oem version. So http://www.dell.com/support/troubleshooting/us/en/04/Product/oth-r620”.
  5. Go to Drivers and Downloads, and find the download for “Identity Module”, I had to switch the OS selector to “Windows Server 2008 x64” to find it. Then hit “Download File”
  6. Now it will offer ~3 different files, one will be similar to “R620_Identity-Module_Application_WCPFW_WN32_1.01_A00.EXE”, stating “Identity-Module_Application”, download this file.
  7. Run this in Windows, it will ask if you are sure and just say yes. It can take up to 5 minutes, MAKE SURE NOTHING INTURUPTS THE SERVER IN THIS TIME.
  8. Reboot the server, and it will come up with the branding again, then it will give a special message once it gets past post similar to “modifying branding”
  9. The system will reboot again, and the branding is gone
  10. Now go into the DOS bootable drive, USB works well, and set the service tag for the system.

Now your OEM box that was impossible to unbrand has been unbranded.

Advertisements

7 comments

  1. Hi danberk, I have an old Google Search Appliance, which is branded Dell OEMR R720xd. I tried all the steps but I was not succesful. I removed Service Tag that worked for me. Then I tried W2012R2, W2008R2, W8.1 but always the same result. I run the Identity Modul Application and after 20-40 seconds something like “not compatable system”. Do you have any idea why? Thanks. Zdenek

      1. Yes, thats the version I tried. I think the difference is that you were removing Dell standard brand but I am trying to remove Google overiding brand, which would be probably placed somewhere in different location. Well I dont know.

    1. See this method only works on older gen servers like 11th or before (R710 series or before) I have never tried going the other way. Sorry I just havent tried. 🙂

  2. Or…you get the WCPFW_R620_CustBSU_1_01.exe file and load it through the iDRAC web GUI in the firmware update section- no need to install an OS.
    Each server for 12Gen and 13Gen should have a board service utility (custBSU file) that can be used- just for this purpose. However Dell does seem to have gaps, like the R220 and R520 CustBSU files are not online for some reason.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s